Input: rename SW_RADIO to SW_RFKILL_ALL

This change “Input: rename SW_RADIO to SW_RFKILL_ALL” (commit 5adad01) in Linux kernel is authored by Henrique de Moraes Holschuh <hmh [at] hmh.eng.br> on Fri May 30 10:40:46 2008 -0400.

Description of "Input: rename SW_RADIO to SW_RFKILL_ALL"

The change “Input: rename SW_RADIO to SW_RFKILL_ALL” introduces changes as follows.

Input: rename SW_RADIO to SW_RFKILL_ALL

The SW_RADIO code for EV_SW events has a name that is not descriptive
enough of its intended function, and could induce someone to think
KEY_RADIO is its EV_KEY counterpart, which is false.

Rename it to SW_RFKILL_ALL, and document what this event is for.  Keep
the old name around, to avoid userspace ABI breaks.

The SW_RFKILL_ALL event is meant to be used by rfkill master switches.  It
is not bound to a particular radio switch type, and usually applies to all
types.  It is semantically tied to master rfkill switches that enable or
disable every radio in a system.

Signed-off-by: Henrique de Moraes Holschuh <hmh@hmh.eng.br>
Signed-off-by: Dmitry Torokhov <dtor@mail.ru>

Linux kernel releases containing commit 5adad01

The Linux kernel releases containing this commit are as follows.

Linux kernel code changes from "Input: rename SW_RADIO to SW_RFKILL_ALL"

There are 4 lines of Linux source code added/deleted in this change. Code changes to Linux kernel are as follows.

 include/linux/input.h | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
 
diff --git a/include/linux/input.h b/include/linux/input.h
index 28a094fcfe20..e075c4b762fb 100644
--- a/include/linux/input.h
+++ b/include/linux/input.h
@@ -637,7 +637,9 @@ struct input_absinfo {
 #define SW_LID			0x00  /* set = lid shut */
 #define SW_TABLET_MODE		0x01  /* set = tablet mode */
 #define SW_HEADPHONE_INSERT	0x02  /* set = inserted */
-#define SW_RADIO		0x03  /* set = radio enabled */
+#define SW_RFKILL_ALL		0x03  /* rfkill master switch, type "any"
+					 set = radio enabled */
+#define SW_RADIO		SW_RFKILL_ALL	/* deprecated */
 #define SW_MAX			0x0f
 #define SW_CNT			(SW_MAX+1)
 

The commit for this change in Linux stable tree is 5adad01 (patch).

Last modified: 2020/02/10