gpiolib: fix incorrect IRQ requesting of an active-low lineevent [Linux 4.14.137]

This Linux kernel change "gpiolib: fix incorrect IRQ requesting of an active-low lineevent" is included in the Linux 4.14.137 release. This change is authored by Michael Wu <michael.wu [at] vatics.com> on Mon Jul 8 13:23:08 2019 +0800. The commit for this change in Linux stable tree is 2a14a26 (patch) which is from upstream commit 223ecaf. […]